New Member

"Print and mail your return" gets a print with "Duplicate/do not send by mail". How do you get a clea print to sent in.

I go through all the steps but "Print to mail" on the last page does not give a clean print to mail in.  It has Duplicate/ do not send by mail" all over it.  It is the same print as several pages before when you saved and printed to pdf. 

New Member

Printing

Within the windows Standard edition, Print Return To Mail and Save PDF of Return to Mail both give me a clean copy without the Duplicate watermark.  Are you sure you’re working with the latest update of Turbo Tax?

New Member

Printing

I am having the same problem - and unless the checking for updates is misleading me. I have the latest version.

Moderator

Printing

Please follow below steps to get a return printed without the watermark:

If you are using the EasyStep Interview, switch to forms by pressing Ctrl+R on your keyboard.

1.  From the File menu, select Print, and then Print Return.

2.  Click Continue button on a screen Save a copy of your return for your records

3. Click Save PDF of Return to Mail

4. Save the PDF file

New Member

Printing

I had the same problem. The issue is that until you choose "Netfile" it doesn't give you the option of printing a clean copy for CRA. When you do, it is actually fairly clear.

 

Good Luck!

New Member

Printing

This doesn't work.

Returning Member

Printing

Has anyone actually been able to fix this? Wasting a lot of time trying to figure this out - extremely frustrating. 

Returning Member

Printing

This doesn't work can you please give a clear way to download it without this. 

New Member

Printing

We're having the same trouble with my mom's final return. Have we decided what the final fix is?

My decided prepared this on a disc version.