SelectTopicList not found

Why sign in to the Community?

  • Submit a question
  • Check your notifications
or and start working on your taxes
EnglishEN

Pick a language

Français English
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

SelectTopicList not found

I was on the phone with support, but I guess they close at 6PM EST, and at 6PM on the dot the line went dead in the middle of the call. I don't think they were really able to help me anyway, since it's obviously a problem with the codebase, and not something like a browser setting.

I'm trying to file my taxes. I get as far as the "Do you have income to report?" screen. I click the "Add" button, which brings up the search dialog, where I want to type "T4" to bring that up. However, as soon as the text input in that dialog receives a keydown event, it pops up a Javascript alert:

"selectTopicList not found"

I'm guessing that this is a debug error handler left in the code, though I obviously can't say what's triggering it.

I've tried in Chrome, Firefox, and Safari, on two different machines, and the behaviour is consistent. I was surprised that the support agent hadn't already fielded calls about this, as if it was happening to everyone, it's kind of a blocker and nobody would be able to file their taxes, so it could be something specific to my account.

Anyway, I'd like to file my taxes, and I've gone far enough in TurboTax that I don't really want to start over with another product, so resolving this would be ideal.

If anyone has any ideas, or if the dev team needs any additional information from me, please let me know.

Thanks.

9 Replies
Highlighted
New Member

SelectTopicList not found

First, thanks for describing the issue you're having in such great detail.

Unfortunately, we're not able to reproduce the error you describe and we're not hearing it from other users. If you're open to experimenting with us a bit, here are some things we'd like to try.

Does the error persist in a copy?

  1. Sign into your TurboTax account and make a copy of your return by selecting the Copy link under your return's name in Return Manager.
  2. Then, open the copy and try the Find function.

If you get an error in the copy...

  1. Open your return (the original or the copy)
  2. Select the Upgrade link under the refund ticker on the left and upgrade to TurboTax Standard.
  3. Then, try the Find function.

If the Standard return works, post back to let me know and we'll zero our the cost of the return so you can finish up.

And if the Standard return doesn't work, certainly let me know that too and we'll try something else.

Highlighted
New Member

SelectTopicList not found

Thanks for the response Tara. The error persists, both in the copy, and after selecting upgrade to TurboTax standard. I'm currently going through the React source and trying to find where the alert is firing, but it's obviously difficult without the unprocessed source code...
Highlighted
New Member

SelectTopicList not found

Obviously if there's anything I can do that will help debug, let me know. I'm a React developer, so am not shy about digging into the source, the Redux store etc etc.
Highlighted
New Member

SelectTopicList not found

Hmm...there seems to be Angular in here too. A lot going on!
Highlighted
New Member

SelectTopicList not found

Ok, I've at least found where the error is happening.

There's an inline script in the main document, a function called search_index.

When called, it tries to set a variable, topicList, from an element on the page with an ID of selectTopicList

var topicList = document.getElementById('selectTopicList');

Now there's no element on the page with that ID, so it obviously returns null.

Next is a simple null check, and the alert:

if (topicList === null) {
    alert('selectTopicList not found');
    return;
}

So there we have it, behaving exactly as you'd expect from the code.

Judging from the code, selectTopicList is supposed to be an HTML select, with references to selectedIndex and options properties. At a guess, it's supposed to appear and populate based on the text entered into the search box. As for why it's not appearing, I have no idea without better access to the source. First thought was if there was an extension or something removing it. That was ruled out by checking in other browsers.

Hopefully this gives you enough info to pass on to your dev team that they should be able to make some sort of sense of it.

Thanks again.
Highlighted
New Member

SelectTopicList not found

Wanna come work here? 🙂

Again, this is awesome. Thanks for this. I've passed this on to our dev team.
Highlighted
New Member

SelectTopicList not found

I just started a new job, but hey, if you can make the right offer, you never know 🙂
Highlighted
New Member

SelectTopicList not found

I was able to work around this in the end by starting over, and not connecting my CRA account in the preceding section. I know it's not a fix, but it was enough to get me through the process. I'm still interested to hear of a proper fix, so please let me know once the dev team have figured it out.

Thanks!
Highlighted
New Member

SelectTopicList not found

Thanks for the additional details! I've passed them on to our dev team.
v