The amount of capital gains from my T5008 is doubl... - Community

Why sign in to the Community?

  • Submit a question
  • Check your notifications
or and start working on your taxes
EnglishEN

Pick a language

Français English
Announcements
For information related to Covid-19 and how to get help if you lost your job, please see The Covid-19 Tax Info Center
cancel
Showing results for 
Search instead for 
Did you mean: 
Intuit

The amount of capital gains from my T5008 is doubled in TurboTax. How do I fix this?

You may have entered the capital gains info from your T5008 twice - once in the T5008 entry step and again in the Investment Profile section.

You only need to enter your T5008 info in the T5008 step; typically, only non-slip based capital gains info is entered in the Investment Profile section.

To remove the T5008 info duplicated in the Investment Profile section:

  1. In the upper-right corner of your screen, select Find*.
  2. In the Find window, type Investments and then select Go.
  3. On the Your Investments Profile screen, make sure you have checked the Capital Gains or Losses (shares, properties, etc.)
  4. On the Capital Gains Profile screen, make sure you have checked the Sold stocks, bonds, real estate or other capital property checkbox and then select Continue.
  5. Delete the information that is entered in the Capital Gains (or Losses) section of the interview that was also entered through the T5008 entry step.

Was this helpful?

You must sign in to vote, reply, or post
Intuit TurboTax - Finish filing and get your maximum refund, guaranteed.

Returning? Sign in